cryptix.provider

Marc Stiegler marcs@skyhunter.com
Tue, 9 Feb 1999 09:39:51 -0700


Ah, since this definitely does not work with Java 1.2, disregard the email I
just sent out about my efforts to use the binaries with 1.2

--marcs

-----Original Message-----
From: Mark S. Miller <markm@erights.org>
To: Marc Stiegler <marcs@skyhunter.com>
Cc: E Language Discussions <e-lang@eros.cis.upenn.edu>
Date: Monday, February 08, 1999 6:23 PM
Subject: Re: cryptix.provider


>Just some quick tentative answers until Tyler responds.
>
>At 05:09 PM 2/8/99 , Marc Stiegler wrote:
>>I just tried to build from the new source zip file, and
>>org.erights.net.data.TripleDESMsgEncryptor expects a number of packages it
>>can't find, notably cryptix.provider.* packages which I don't have in my
>>cryptix zip. Is there a new cryptix to go with this?
>
>[+] Definitely do not use your old cryptix.zip.
>It was domestically modified at EC, and therefore non-distributable.  Tyler
>has been using cryptix as distributed internationally by Systemics.  Tyler,
>what URL should one download from?
>
>
>>Also, another surprise to me was that the source download doesn't have
>>anything associated with cryptix, as nearly as I can tell. Shouldn't the
>>cryptix zip be in this distribution too, so you can create a complete
>>functional system from without multiple downloads? Cryptix is not
mentioned
>>anywhere.
>
>[+] Good point.
>If we can't bundle it into to the download files (I don't remember what the
>license constraints might be), then we should provide a link to their
>download page, just like we do for Cygwin.
>
>
>>TripleDESMsgEncryptor has more trouble than just cryptix.provider. It is
>>also looking for java.security.WeakKeyException, java.security.Cipher. I
am
>>using IBM Vis-Age, which is a Java 1.1.6 environment.
>>
>>Ah, I am coming to the conclusion this requires Java 1.2. Is that true? If
>>so, you better tell people so on the Web page, else they'll be as confused
>>as I :-) Argh, I just realized, if this is true, I'll have to forsake my
>>development environment to compile! Maybe I'll just go with the binaries
:-)
>
>Definitely NOT 1.2.  E works only with a 1.1.x for some value of x.  Tyler?