A stab at the sealer in E
Wed, 3 Nov 1999 20:47:53 -0700
As far as brand/seal and box/envelope, I agree envelope is better. Most of
my names were a little funny just to avoid having it appear as if I were
using the built-in primitives. I'm indifferent on brand/seal; certainly,
sealSystemMaker is wrong for a "primitive" (no longer built in :-).
The convention is currently "new", not "make". Markm and I had long
discussions about that a long time ago, and I persuaded him to use "new"
because it will supply another moment of comfort for the java programmer
just learning E. So I am indeed the guy to blame :-)
----- Original Message -----
From: Ka-Ping Yee <firstname.lastname@example.org>
To: Marc Stiegler <email@example.com>
Cc: Mark S. Miller <firstname.lastname@example.org>; Chip Morningstar
<email@example.com>; <firstname.lastname@example.org>; <email@example.com>
Sent: Wednesday, November 03, 1999 7:57 PM
Subject: Re: A stab at the sealer in E
> On Wed, 3 Nov 1999, Marc Stiegler wrote:
> > Well, since it looks like this sealer might actually be useful, here is
> > cleaned up version that to the best of my knowledge fully implements the
> > kernel BrandMaker semantics.
> Can we try to get the terminology straightened out though?
> Is it Brand or BrandMaker or sealSystemMaker? SealedBox, Box, or
> I think i'll vote for either SealMaker or BrandMaker, and Envelope.
> Is the constructor method conventionally to be called "make" or
> I think i'll vote for "make", since it's a verb.
> -- ?!ng
> "The biggest cause of trouble in the world today is that the stupid people
> are so sure about things and the intelligent folk are so full of doubts."
> -- Bertrand Russell