[e-lang] Operator Renaming

Mark S. Miller e-lang@mail.eros-os.org
Wed, 05 Jun 2002 00:08:58 -0700

I just re-skimmed the old thread rooted at 
http://www.eros-os.org/pipermail/e-lang/2001-April/005069.html .  It seems 
the operator expansions renamings we agree to are

compareTo    -> op__cmp
run          -> op__call
get          -> op__getitem
set          -> op__setitem
add          -> op__add
subtract     -> op__sub
negate       -> op__neg
multiply     -> op__mul
floorDivide  -> op__floorDiv
approxDivide -> op__approxDiv
remainder    -> op__remainder
mod          -> op__mod
pow          -> op__pow
leftShift    -> op__lshift
and          -> op__and
xor          -> op__xor
or           -> op__or
complement   -> op__invert
butNot       -> op__mask
not          -> op__not

Without some such renaming, Ping's desire for 'and', 'or' and 'not' keywords 
cannot be accommodated.  Also, for all the reasons stated in that thread, 
these renamings are probably a good idea in their own right.  Does anyone 
have any objection to this happening soon, given that the old names are 
deprecated but supported during the transition?

Text by me above is hereby placed in the public domain