[e-lang] bug report: E on Java with SWT on Mac OS 10

Zooko O'Whielacronx zooko at zooko.com
Fri Dec 24 16:22:27 EST 2004


Dear e-lang mailing list and Andre Weinand:

This bug report [1] seems to describe the current problem with running 
E/Java [2] with SWT on Mac OS 10:

However, when I tried the suggested fix -- using "java_swt" instead of 
"java" -- I get different behavior but not working behavior.

"rune --version" reports:

E version: ?? at /usr/local/stow/e/e/
on Java version: 1.4.2_05 at 
/System/Library/Frameworks/JavaVM.framework/Versions/1.4.2/Home
on OS: Mac OS X version: 10.3.7 on ppc (Darwin/Power Macintosh)
for zooko in US

I'm not sure why the E version is missing.  I'm using E 0.8.33b, 
installed with my "inst-e.bash" script with a couple of tweaks.

I'm using SWT 3063 (which comes with Eclipse 3.0.1).


If I run the following cmdline:

rune -cpa "/usr/local/lib/swt.jar:/usr/local/lib/swt-pi.jar" 
-Djava.library.path="/usr/local/lib" /usr/local/e/scripts/minChat.e-swt

... I get the minchat window, but no menu.  It appears to be unable to 
receive focus or to receive key or mouse events.  The Mac OS 10 
"currently running applications" menu (alt-tab) doesn't include any 
entry for java, e, or minchat.  I can click on the red "close" button 
to make the app go away.

(By the way, this experiment takes between 30 and 60 seconds, which 
makes this kind of experimentation tedious...)


If I edit rune and set JCMD to java_swt, then I get the minchat GUI 
with the "spinning beachball" mouse pointer showing that it is not 
responding.  There is still no menu.  "java_swt" appears in the 
currently running applications list.  I can't click the red "close" 
button, so I have to stop the program by returning to the command-line 
and hitting C-c.


Regards,

Zooko

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=40003
[2] http://erights.org/



More information about the e-lang mailing list