[e-lang] Rename Guard, ValueGuard (was Re: Conflict of principles)
markm at cs.jhu.edu
Fri Sep 2 08:10:48 EDT 2005
Kevin Reid wrote:
> Also, the names Guard and ValueGuard are leftovers from the SlotGuard
> days. I propose renaming ValueGuard to Guard and Guard to -- something
> I haven't thought of a decent name for Guard, though; just
> ExtendedGuard, SugaredGuard, FancyGuard, etc., which might be true but
> don't really say anything.
Agreed. This change should also have minimal impact on existing code. If there
are no objections, I'll do this for the next release.
Unless someone thinks of something better, I'll go with "ExtendedGuard".
Text by me above is hereby placed in the public domain
More information about the e-lang