[e-lang] Documentation bug for FlexList
tribble at e-dean.com
Sat Mar 17 22:27:23 CDT 2007
I think I would like both that little pun and the use of assignment sugar
for that operation went away. I find "replace" a much clearer name for the
operation, but then I came from Smalltalk :)
On 3/16/07, Kevin Reid <kpreid at mac.com> wrote:
> I hadn't intended to say that in particular. E does make that pun,
> however; "run" is used for both "running" a subroutine (function) and
> taking a "run" (subsequence) of a collection.
> But my point was that there is a sugar which expands to this
> operation on lists, and that either the sugar must be changed to
> match, the interface be duplicated, or the sugar removed (or no
> longer be usable for this purpose).
> Personally, I do not find the notion of "replacing" a subsequence
> with a different-length subsequence at all odd, so I have no problem
> with the replace/5 name. I wouldn't mind changing setRun/3 to
> replaceRun/3 if we agree that it's an improvement and that it works
> with non-list objects (or to discard the sugar connection);
> "insertRun" I find to be wrong in the case where the specified range
> is not zero-length.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the e-lang